What’s Vulnerable › Vulnerabilities
CVE-2025-3901: Bootstrap Site Alert - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-042
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Bootstrap Site Alert allows Cross-Site Scripting (XSS).This issue affects Bootstrap Site Alert: from 0.0.0 before 1.13.0, from 3.0.0 before 3.0.4.
Affected products
- Drupal Bootstrap Site Alert: before 1.13.0; from 3.0.0 before 3.0.4; from 8.x-1.0 before 8.x-1.13 — fixed in 1.13.0, 3.0.4, 8.x-1.13
How to fix
Upgrade to a fixed version: Drupal Bootstrap Site Alert 1.13.0, 3.0.4, 8.x-1.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3901 or the next vulnerability affects your stack