What’s Vulnerable › Vulnerabilities
CVE-2025-3902: Block Class - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-043
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Block Class allows Cross-Site Scripting (XSS).This issue affects Block Class: from 4.0.0 before 4.0.1.
Affected products
- Drupal Block Class: from 4.0.0 before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Drupal Block Class 4.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3902 or the next vulnerability affects your stack