What’s Vulnerable › Vulnerabilities
CVE-2025-3907: Search API Solr - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-046
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-23 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Search API Solr allows Cross Site Request Forgery.This issue affects Search API Solr: from 0.0.0 before 4.3.9.
Affected products
- Drupal Search API Solr: before 4.3.9 — fixed in 4.3.9
How to fix
Upgrade to a fixed version: Drupal Search API Solr 4.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-3907 or the next vulnerability affects your stack