What’s Vulnerable › Vulnerabilities

CVE-2025-3913: Team Privacy Settings Authorization Bypass in Mattermost Server

Description

Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly validate permissions when changing team privacy settings, allowing team administrators without the 'invite user' permission to access and modify team invite IDs via the /api/v4/teams/:teamId/privacy endpoint.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.4, 10.6.3, 10.7.1, 9.11.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-3913 or the next vulnerability affects your stack