What’s Vulnerable › Vulnerabilities
CVE-2025-3914: Aeropage Sync for Airtable <= 3.2.0 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-26 · updated 2026-06-17
- Weakness: CWE-434
Description
The Aeropage Sync for Airtable plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'aeropage_media_downloader' function in all versions up to, and including, 3.2.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- Aeropage Sync for Airtable: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: Aeropage Sync for Airtable 3.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/aeropage-sync-for-airtable/trunk/aeropage.php#L1214
- https://plugins.trac.wordpress.org/browser/aeropage-sync-for-airtable/trunk/aeropage.php#L1215
- https://plugins.trac.wordpress.org/browser/aeropage-sync-for-airtable/trunk/aeropage.php#L1250
- https://plugins.trac.wordpress.org/changeset/3281904/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a501c2d6-cdcc-4003-99df-245f5253e20f?source=cve
Get alerted when CVE-2025-3914 or the next vulnerability affects your stack