What’s Vulnerable › Vulnerabilities
CVE-2025-3915: Aeropage Sync for Airtable <= 3.2.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-26 · updated 2026-06-17
- Weakness: CWE-862
Description
The Aeropage Sync for Airtable plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'aeropageDeletePost' function in all versions up to, and including, 3.2.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary posts.
Affected products
- Aeropage Sync for Airtable: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: Aeropage Sync for Airtable 3.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/aeropage-sync-for-airtable/trunk/aeropage.php#L475
- https://plugins.trac.wordpress.org/browser/aeropage-sync-for-airtable/trunk/aeropage.php#L476
- https://plugins.trac.wordpress.org/changeset/3281904/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f98aab54-877b-47df-9c8a-5e70ea985c1c?source=cve
Get alerted when CVE-2025-3915 or the next vulnerability affects your stack