What’s Vulnerable › Vulnerabilities
CVE-2025-3925: BrightSign Players Execution with Unnecessary Privileges
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-07 · updated 2026-06-17
- Weakness: CWE-250
Description
BrightSign players running BrightSign OS series 4 prior to v8.5.53.1 or series 5 prior to v9.0.166 contain an execution with unnecessary privileges vulnerability, allowing for privilege escalation on the device once code execution has been obtained.
Affected products
- BrightSign OS series 4 players: before v8.5.53.1 — fixed in v8.5.53.1
- BrightSign OS series 5 players: before v9.0.166 — fixed in v9.0.166
How to fix
Upgrade to a fixed version: BrightSign OS series 4 players v8.5.53.1; BrightSign OS series 5 players v9.0.166. Check the vendor advisory for mitigations.
References
- https://www.brightsign.biz/resources/software-downloads/
- https://www.cisa.gov/news-events/ics-advisories/icsa-25-126-03
Get alerted when CVE-2025-3925 or the next vulnerability affects your stack