What’s Vulnerable › Vulnerabilities
CVE-2025-39361: WordPress Royal Elementor Addons plugin <= 1.7.1017 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Royal Royal Elementor Addons royal-elementor-addons allows Stored XSS.This issue affects Royal Elementor Addons: from n/a through <= 1.7.1017.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.7.1018 — fixed in 1.7.1018
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.7.1018. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-39361 or the next vulnerability affects your stack