What’s Vulnerable › Vulnerabilities
CVE-2025-39400: WordPress User Registration plugin < 4.2.0 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpeverest User Registration user-registration allows Reflected XSS.This issue affects User Registration: from n/a through < 4.2.0.
Affected products
- User Registration & Membership: before 4.2.0; before 5.2.0 — fixed in 4.2.0, 5.2.0
How to fix
Upgrade to a fixed version: User Registration & Membership 4.2.0, 5.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-39400 or the next vulnerability affects your stack