What’s Vulnerable › Vulnerabilities
CVE-2025-3951: WP-Optimize < 4.2.0 - Admin+ SQLi
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP-Optimize WordPress plugin before 4.2.0 does not properly escape user input when checking image compression statuses, which could allow users with the administrator role to conduct SQL Injection attacks in the context of Multi-Site WordPress configurations.
Affected products
- WP-Optimize: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: WP-Optimize 4.2.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/220c195f-3df3-4883-8e0b-a0cf019e6323/
- https://wpscan.com/vulnerability/220c195f-3df3-4883-8e0b-a0cf019e6323/
Get alerted when CVE-2025-3951 or the next vulnerability affects your stack