What’s Vulnerable › Vulnerabilities
CVE-2025-39589: WordPress Essential Addons for Elementor plugin <= 6.1.9 - Sensitive Data Exposure Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-497
Description
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in WPDeveloper Essential Addons for Elementor essential-addons-for-elementor-lite allows Retrieve Embedded Sensitive Data.This issue affects Essential Addons for Elementor: from n/a through <= 6.1.9.
Affected products
- wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets: before 6.1.10 — fixed in 6.1.10
How to fix
Upgrade to a fixed version: wpdevteam Essential Addons for Elementor – Popular Elementor Templates & Widgets 6.1.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-39589 or the next vulnerability affects your stack