What’s Vulnerable › Vulnerabilities
CVE-2025-39663: Cross Site Scripting through compromised remote site
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-30 · updated 2026-10-19
- Weakness: CWE-80
Description
Cross-Site Scripting (XSS) vulnerability in Checkmk's distributed monitoring allows a compromised remote site to inject malicious HTML code into service outputs in the central site. Affecting Checkmk before 2.4.0p14, 2.3.0p39, 2.2.0 and 2.1.0 (eol).
Affected products
- Checkmk GmbH Checkmk: from 2.0.0 before 2.3.0; 2.3.0, 2.3.0-p1, 2.3.0-p10, 2.3.0-p11, 2.3.0-p12, 2.3.0-p13 (+46) — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Checkmk GmbH Checkmk 2.3.0. Check the vendor advisory for mitigations.
References
- https://checkmk.com/werk/17998
- https://github.com/sbaresearch/advisories/tree/82fd27e4570433464c30b35150b197db9a850f4e/2025/SBA-ADV-20250729-01_Checkmk_Cross_Site_Scripting
- http://seclists.org/fulldisclosure/2025/Nov/0
- https://github.com/sbaresearch/advisories/tree/82fd27e4570433464c30b35150b197db9a850f4e/2025/SBA-ADV-20250729-01_Checkmk_Cross_Site_Scripting
Get alerted when CVE-2025-39663 or the next vulnerability affects your stack