What’s Vulnerable › Vulnerabilities
CVE-2025-39676: scsi: qla4xxx: Prevent a potential error pointer dereference
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-10-19
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qla4xxx: Prevent a potential error pointer dereference The qla4xxx_get_ep_fwdb() function is supposed to return NULL on error, but qla4xxx_ep_connect() returns error pointers. Propagating the error pointers will lead to an Oops in the caller, so change the error pointers to NULL.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.2.1 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.44 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.149, 6.12.44, 6.16.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.149. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/325bf7d57c4e2a341e381c5805e454fb69dd78c3
- https://git.kernel.org/stable/c/46288d12d1c30d08fbeffd05abc079f57a43a2d4
- https://git.kernel.org/stable/c/9dcf111dd3e7ed5fce82bb108e3a3fc001c07225
- https://git.kernel.org/stable/c/ad8a9d38d30c691a77c456e72b78f7932d4f234d
- https://git.kernel.org/stable/c/d0225f41ee70611ca88ccb22c8542ecdfa7faea8
- https://git.kernel.org/stable/c/f1424c830d6ce840341aac33fe99c8ac45447ac1
- https://git.kernel.org/stable/c/f4bc3cdfe95115191e24592bbfc15f1d4a705a75
- https://git.kernel.org/stable/c/f5ad0819f902b4b33591791b92a0350fb3692a6b
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39676 or the next vulnerability affects your stack