What’s Vulnerable › Vulnerabilities
CVE-2025-39685: comedi: pcl726: Prevent invalid irq number
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: comedi: pcl726: Prevent invalid irq number The reproducer passed in an irq number(0x80008000) that was too large, which triggered the oob. Added an interrupt number check to prevent users from passing in an irq number that was too large. If `it->options[1]` is 31, then `1 << it->options[1]` is still invalid because it shifts a 1-bit into the sign bit (which is UB in C). Possible solutions include reducing the upper bound on the `it->options[1]` value to 30 or lower, or using `1U << it->options[1]`. The old code would just not attempt to request the IRQ if the `options[1]` value were invalid. And it would still configure the device without interrupts even if the call to `request_irq` returned an error. So it would be better to combine this test with the test below.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.13 before 5.15.190; from 5.16 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.44; from 6.13 before 6.16.4; 6.17-rc1, 6.17-rc2 — fixed in 5.15.190, 6.1.149, 6.12.44, 6.16.4, 6.6.103
How to fix
Upgrade to a fixed version: Linux kernel 5.15.190, 6.1.149, 6.12.44, 6.16.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0eb4ed2aa261dee228f1668dbfa6d87353e8162d
- https://git.kernel.org/stable/c/5a33d07c94ba91306093e823112a7aa9727549f6
- https://git.kernel.org/stable/c/96cb948408b3adb69df7e451ba7da9d21f814d00
- https://git.kernel.org/stable/c/a3cfcd0c78c80ca7cd80372dc28f77d01be57bf6
- https://git.kernel.org/stable/c/bab220b0bb5af652007e278e8e8357f952b0e1ea
- https://git.kernel.org/stable/c/d8992c9a01f81128f36acb7c5755530e21fcd059
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39685 or the next vulnerability affects your stack