What’s Vulnerable › Vulnerabilities
CVE-2025-39701: ACPI: pfr_update: Fix the driver update version check
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: ACPI: pfr_update: Fix the driver update version check The security-version-number check should be used rather than the runtime version check for driver updates. Otherwise, the firmware update would fail when the update binary had a lower runtime version number than the current one. [ rjw: Changelog edits ]
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.17 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.44; from 6.13 before 6.16.4; 6.17-rc1, 6.17-rc2 — fixed in 6.1.149, 6.12.44, 6.16.4, 6.6.103
How to fix
Upgrade to a fixed version: Linux kernel 6.1.149, 6.12.44, 6.16.4, 6.6.103. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/79300ff532bccbbf654992c7c0863b49a6c3973c
- https://git.kernel.org/stable/c/8151320c747efb22d30b035af989fed0d502176e
- https://git.kernel.org/stable/c/908094681f645d3a78e18ef90561a97029e2df7b
- https://git.kernel.org/stable/c/b00219888c11519ef75d988fa8a780da68ff568e
- https://git.kernel.org/stable/c/cf0a88124e357bffda487cbf3cb612bb97eb97e4
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39701 or the next vulnerability affects your stack