What’s Vulnerable › Vulnerabilities
CVE-2025-39716: parisc: Revise __get_user() to probe user read access
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: parisc: Revise __get_user() to probe user read access Because of the way read access support is implemented, read access interruptions are only triggered at privilege levels 2 and 3. The kernel executes at privilege level 0, so __get_user() never triggers a read access interruption (code 26). Thus, it is currently possible for user code to access a read protected address via a system call. Fix this by probing read access rights at privilege level 3 (PRIV_USER) and setting __gu_err to -EFAULT (-14) if access isn't allowed. Note the cmpiclr instruction does a 32-bit compare because COND macro doesn't work inside asm.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.13 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.44; from 6.13 before 6.16.4; 2.6.12, 2.6.12-rc2, 2.6.12-rc3, 2.6.12-rc4, 2.6.12-rc5 — fixed in 6.1.149, 6.12.44, 6.16.4, 6.6.103
How to fix
Upgrade to a fixed version: Linux kernel 6.1.149, 6.12.44, 6.16.4, 6.6.103. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/28a9b71671fb4a2993ef85b8ef6f117ea63894fe
- https://git.kernel.org/stable/c/4c981077255acc2ed5b3df6e8dd0125c81b626a9
- https://git.kernel.org/stable/c/741b163e440683195b8fd4fc8495fcd0105c6ab7
- https://git.kernel.org/stable/c/89f686a0fb6e473a876a9a60a13aec67a62b9a7e
- https://git.kernel.org/stable/c/f410ef9a032caf98117256b22139c31342d7bb06
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39716 or the next vulnerability affects your stack