What’s Vulnerable › Vulnerabilities
CVE-2025-39727: mm: swap: fix potential buffer overflow in setup_clusters()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-07 · updated 2026-10-19
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: mm: swap: fix potential buffer overflow in setup_clusters() In setup_swap_map(), we only ensure badpages are in range (0, last_page]. As maxpages might be < last_page, setup_clusters() will encounter a buffer overflow when a badpage is >= maxpages. Only call inc_cluster_info_page() for badpage which is < maxpages to fix the issue.
Affected products
- Linux kernel: from 6.12 before 6.12.42; from 6.13 before 6.15.10; from 6.16 before 6.16.1 — fixed in 6.12.42, 6.15.10, 6.16.1
How to fix
Upgrade to a fixed version: Linux kernel 6.12.42, 6.15.10, 6.16.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/152c1339dc13ad46f1b136e8693de15980750835
- https://git.kernel.org/stable/c/815c528b13f2bb9b3130c13bedeabf2351a68129
- https://git.kernel.org/stable/c/91b370800b3f2b3dda244c0ab06719c4971190a5
- https://git.kernel.org/stable/c/9b01ada580ee84fb319e7ecb5fb5b1f54a9eb799
Get alerted when CVE-2025-39727 or the next vulnerability affects your stack