What’s Vulnerable › Vulnerabilities
CVE-2025-39730: NFS: Fix filehandle bounds checking in nfs_fh_to_dentry()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-07 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: NFS: Fix filehandle bounds checking in nfs_fh_to_dentry() The function needs to check the minimal filehandle length before it can access the embedded filehandle.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.13 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.148; from 6.2 before 6.6.102; from 6.7 before 6.12.42 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.148, 6.12.42, 6.15.10
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.148. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/12ad3def2e5e0b120e3d0cb6ce8b7b796819ad40
- https://git.kernel.org/stable/c/2ad40b7992aa26bc631afc1a995b0e3ddc30de3f
- https://git.kernel.org/stable/c/3570ef5c31314c13274c935a20b91768ab5bf412
- https://git.kernel.org/stable/c/763810bb883cb4de412a72f338d80947d97df67b
- https://git.kernel.org/stable/c/7dd36f7477d1e03a1fcf8d13531ca326c4fb599f
- https://git.kernel.org/stable/c/7f8eca87fef7519e9c41f3258f25ebc2752247ee
- https://git.kernel.org/stable/c/b7f7866932466332a2528fda099000b035303485
- https://git.kernel.org/stable/c/cb09afa0948d96b1e385d609ed044bb1aa043536
- https://git.kernel.org/stable/c/ef93a685e01a281b5e2a25ce4e3428cf9371a205
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39730 or the next vulnerability affects your stack