What’s Vulnerable › Vulnerabilities
CVE-2025-39743: jfs: truncate good inode pages when hard link is 0
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-11 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: jfs: truncate good inode pages when hard link is 0 The fileset value of the inode copy from the disk by the reproducer is AGGR_RESERVED_I. When executing evict, its hard link number is 0, so its inode pages are not truncated. This causes the bugon to be triggered when executing clear_inode() because nrpages is greater than 0.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.14 before 5.4.297; from 5.5 before 5.10.241; from 5.11 before 5.15.190; from 5.16 before 6.1.149; from 6.2 before 6.6.103; from 6.7 before 6.12.43 — fixed in 5.10.241, 5.15.190, 5.4.297, 6.1.149, 6.12.43, 6.15.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.241, 5.15.190, 5.4.297, 6.1.149. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1bb5cdc3e39f0c2b311fcb631258b7e60d3fb0d3
- https://git.kernel.org/stable/c/2b1d5ca395a5fb170c3f885cd42c16179f7f54ec
- https://git.kernel.org/stable/c/2d91b3765cd05016335cd5df5e5c6a29708ec058
- https://git.kernel.org/stable/c/34d8e982bac48bdcca7524644a8825a580edce74
- https://git.kernel.org/stable/c/5845b926c561b8333cd65169526eec357d7bb449
- https://git.kernel.org/stable/c/89fff8e3d6710fc32507b8e19eb5afa9fb79b896
- https://git.kernel.org/stable/c/8ed7275910fb7177012619864e04d3008763f3ea
- https://git.kernel.org/stable/c/b5b471820c33365a8ccd2d463578bf4e47056c2c
- https://git.kernel.org/stable/c/df3fd8daf278eca365f221749ae5b728e8382a04
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39743 or the next vulnerability affects your stack