What’s Vulnerable › Vulnerabilities
CVE-2025-39755: staging: gpib: Fix cb7210 pcmcia Oops
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-18 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: staging: gpib: Fix cb7210 pcmcia Oops The pcmcia_driver struct was still only using the old .name initialization in the drv field. This led to a NULL pointer deref Oops in strcmp called from pcmcia_register_driver. Initialize the pcmcia_driver struct name field.
Affected products
- Linux kernel: from 6.13 before 6.13.11; from 6.14 before 6.14.2 — fixed in 6.13.11, 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 6.13.11, 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7ec50077d7f6647cb6ba3a2a20a6c26f51259c7d
- https://git.kernel.org/stable/c/c1baf6528bcfd6a86842093ff3f8ff8caf309c12
- https://git.kernel.org/stable/c/c82ae06f49e70d1c14ee9c76c392345856d050c9
Get alerted when CVE-2025-39755 or the next vulnerability affects your stack