What’s Vulnerable › Vulnerabilities
CVE-2025-39803: scsi: ufs: core: Remove WARN_ON_ONCE() call from ufshcd_uic_cmd_compl()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-10-19
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: ufs: core: Remove WARN_ON_ONCE() call from ufshcd_uic_cmd_compl() The UIC completion interrupt may be disabled while an UIC command is being processed. When the UIC completion interrupt is reenabled, an UIC interrupt is triggered and the WARN_ON_ONCE(!cmd) statement is hit. Hence this patch that removes this kernel warning.
Affected products
- Linux kernel: from 6.13 before 6.16.4; 6.17-rc1, 6.17-rc2 — fixed in 6.16.4
How to fix
Upgrade to a fixed version: Linux kernel 6.16.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/c0cc24c139e0f62859dbf88e050ba074cd93988f
- https://git.kernel.org/stable/c/e5203d89d59bfcbe1f348aa0d2dc4449a8ba644c
Get alerted when CVE-2025-39803 or the next vulnerability affects your stack