What’s Vulnerable › Vulnerabilities
CVE-2025-39815: RISC-V: KVM: fix stack overrun when loading vlenb
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: RISC-V: KVM: fix stack overrun when loading vlenb The userspace load can put up to 2048 bits into an xlen bit stack buffer. We want only xlen bits, so check the size beforehand.
Affected products
- Linux kernel: from 6.8 before 6.12.45; from 6.13 before 6.16.5; 6.17-rc1, 6.17-rc2, 6.17-rc3 — fixed in 6.12.45, 6.16.5
How to fix
Upgrade to a fixed version: Linux kernel 6.12.45, 6.16.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6d28659b692a0212f360f8bd8a58712b339f9aac
- https://git.kernel.org/stable/c/799766208f09f95677a9ab111b93872d414fbad7
- https://git.kernel.org/stable/c/c76bf8359188a11f8fd790e5bbd6077894a245cc
Get alerted when CVE-2025-39815 or the next vulnerability affects your stack