What’s Vulnerable › Vulnerabilities
CVE-2025-39817: efivarfs: Fix slab-out-of-bounds in efivarfs_d_compare
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: efivarfs: Fix slab-out-of-bounds in efivarfs_d_compare Observed on kernel 6.6 (present on master as well): BUG: KASAN: slab-out-of-bounds in memcmp+0x98/0xd0 Call trace: kasan_check_range+0xe8/0x190 __asan_loadN+0x1c/0x28 memcmp+0x98/0xd0 efivarfs_d_compare+0x68/0xd8 __d_lookup_rcu_op_compare+0x178/0x218 __d_lookup_rcu+0x1f8/0x228 d_alloc_parallel+0x150/0x648 lookup_open.isra.0+0x5f0/0x8d0 open_last_lookups+0x264/0x828 path_openat+0x130/0x3f8 do_filp_open+0x114/0x248 do_sys_openat2+0x340/0x3c0 __arm64_sys_openat+0x120/0x1a0 If dentry->d_name.len < EFI_VARIABLE_GUID_LEN , 'guid' can become negative, leadings to oob. The issue can be triggered by parallel lookups using invalid filename: T1 T2 lookup_open ->lookup simple_lookup d_add // invalid dentry is added to hash list lookup_open d_alloc_parallel __d_lookup_rcu __d_lookup_rcu_op_compare hlist_bl_for_each_entry_rcu // invalid dentry can be retrieved ->d_compare efivarfs_d_compare // oob Fix it by checking 'guid' before cmp.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.8.2 before 5.4.298; from 5.5 before 5.10.242; from 5.11 before 5.15.191; from 5.16 before 6.1.150; from 6.2 before 6.6.104; from 6.7 before 6.12.45 — fixed in 5.10.242, 5.15.191, 5.4.298, 6.1.150, 6.12.45, 6.16.5
How to fix
Upgrade to a fixed version: Linux kernel 5.10.242, 5.15.191, 5.4.298, 6.1.150. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f63fbabeaaaaaaf5b742a2f4c1b4590d50bf1f6
- https://git.kernel.org/stable/c/568e7761279b99c6daa3002290fd6d8047ddb6d2
- https://git.kernel.org/stable/c/71581a82f38e5a4d807d71fc1bb59aead80ccf95
- https://git.kernel.org/stable/c/794399019301944fd6d2e0d7a51b3327e26c410e
- https://git.kernel.org/stable/c/925599eba46045930b850a98ae594d2e3028ac40
- https://git.kernel.org/stable/c/a6358f8cf64850f3f27857b8ed8c1b08cfc4685c
- https://git.kernel.org/stable/c/c2925cd6207079c3f4d040d082515db78d63afbf
- https://git.kernel.org/stable/c/d7f5e35e70507d10cbaff5f9e194ed54c4ee14f7
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39817 or the next vulnerability affects your stack