What’s Vulnerable › Vulnerabilities
CVE-2025-39823: KVM: x86: use array_index_nospec with indices that come from guest
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-10-19
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: KVM: x86: use array_index_nospec with indices that come from guest min and dest_id are guest-controlled indices. Using array_index_nospec() after the bounds checks clamps these values to mitigate speculative execution side-channels.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.19 before 5.4.298; from 5.5 before 5.10.242; from 5.11 before 5.15.191; from 5.16 before 6.1.150; from 6.2 before 6.6.104; from 6.7 before 6.12.45 — fixed in 5.10.242, 5.15.191, 5.4.298, 6.1.150, 6.12.45, 6.16.5
How to fix
Upgrade to a fixed version: Linux kernel 5.10.242, 5.15.191, 5.4.298, 6.1.150. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/31a0ad2f60cb4816e06218b63e695eb72ce74974
- https://git.kernel.org/stable/c/33e974c2d5a82b2f9d9ba0ad9cbaabc1c8e3985f
- https://git.kernel.org/stable/c/67a05679621b7f721bdba37a5d18665d3aceb695
- https://git.kernel.org/stable/c/72777fc31aa7ab2ce00f44bfa3929c6eabbeaf48
- https://git.kernel.org/stable/c/c87bd4dd43a624109c3cc42d843138378a7f4548
- https://git.kernel.org/stable/c/d51e381beed5e2f50f85f49f6c90e023754efa12
- https://git.kernel.org/stable/c/f49161646e03d107ce81a99c6ca5da682fe5fb69
- https://git.kernel.org/stable/c/f57a4bd8d6cb5af05b8ac1be9098e249034639fb
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39823 or the next vulnerability affects your stack