What’s Vulnerable › Vulnerabilities
CVE-2025-39849: wifi: cfg80211: sme: cap SSID length in __cfg80211_connect_result()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-10-19
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: cfg80211: sme: cap SSID length in __cfg80211_connect_result() If the ssid->datalen is more than IEEE80211_MAX_SSID_LEN (32) it would lead to memory corruption so add some bounds checking.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 6.1.16 before 6.1.151; from 6.2.3 before 6.6.105; from 6.7 before 6.12.46; from 6.13 before 6.16.6; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4 — fixed in 6.1.151, 6.12.46, 6.16.6, 6.6.105
How to fix
Upgrade to a fixed version: Linux kernel 6.1.151, 6.12.46, 6.16.6, 6.6.105. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/31229145e6ba5ace3e9391113376fa05b7831ede
- https://git.kernel.org/stable/c/5cb7cab7adf9b1e6a99e2081b0e30e9e59d07523
- https://git.kernel.org/stable/c/62b635dcd69c4fde7ce1de4992d71420a37e51e3
- https://git.kernel.org/stable/c/8e751d46336205abc259ed3990e850a9843fb649
- https://git.kernel.org/stable/c/e472f59d02c82b511bc43a3f96d62ed08bf4537f
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-39849 or the next vulnerability affects your stack