What’s Vulnerable › Vulnerabilities
CVE-2025-39864: wifi: cfg80211: fix use-after-free in cmp_bss()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: cfg80211: fix use-after-free in cmp_bss() Following bss_free() quirk introduced in commit 776b3580178f ("cfg80211: track hidden SSID networks properly"), adjust cfg80211_update_known_bss() to free the last beacon frame elements only if they're not shared via the corresponding 'hidden_beacon_bss' pointer.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.4 before 5.4.299; from 5.5 before 5.10.243; from 5.11 before 5.15.192; from 5.16 before 6.1.151; from 6.2 before 6.6.105; from 6.7 before 6.12.46 — fixed in 5.10.243, 5.15.192, 5.4.299, 6.1.151, 6.12.46, 6.16.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.243, 5.15.192, 5.4.299, 6.1.151. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/26e84445f02ce6b2fe5f3e0e28ff7add77f35e08
- https://git.kernel.org/stable/c/5b7ae04969f822283a95c866967e42b4d75e0eef
- https://git.kernel.org/stable/c/6854476d9e1aeaaf05ebc98d610061c2075db07d
- https://git.kernel.org/stable/c/912c4b66bef713a20775cfbf3b5e9bd71525c716
- https://git.kernel.org/stable/c/a8bb681e879ca3c9f722aa08d3d7ae41c42a8807
- https://git.kernel.org/stable/c/a97a9791e455bb0cd5e7a38b5abcb05523d4e21c
- https://git.kernel.org/stable/c/b7d08929178c16398278613df07ad65cf63cce9d
- https://git.kernel.org/stable/c/ff040562c10a540b8d851f7f4145fa112977f853
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
- https://cert-portal.siemens.com/productcert/html/ssa-089022.html
Get alerted when CVE-2025-39864 or the next vulnerability affects your stack