What’s Vulnerable › Vulnerabilities
CVE-2025-39870: dmaengine: idxd: Fix double free in idxd_setup_wqs()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-19
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: dmaengine: idxd: Fix double free in idxd_setup_wqs() The clean up in idxd_setup_wqs() has had a couple bugs because the error handling is a bit subtle. It's simpler to just re-write it in a cleaner way. The issues here are: 1) If "idxd->max_wqs" is <= 0 then we call put_device(conf_dev) when "conf_dev" hasn't been initialized. 2) If kzalloc_node() fails then again "conf_dev" is invalid. It's either uninitialized or it points to the "conf_dev" from the previous iteration so it leads to a double free. It's better to free partial loop iterations within the loop and then the unwinding at the end can handle whole loop iterations. I also renamed the labels to describe what the goto does and not where the goto was located.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 6.1.140 before 6.1.153; from 6.6.92 before 6.6.107; from 6.12.30 before 6.12.48; from 6.14.8 before 6.15; from 6.15.1 before 6.16.8; 6.15, 6.15-rc7, 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4 (+1) — fixed in 6.1.153, 6.12.48, 6.15, 6.16.8, 6.6.107
How to fix
Upgrade to a fixed version: Linux kernel 6.1.153, 6.12.48, 6.15, 6.16.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/25e6146c2812487a88f619d5ff6efbdcd5b2bc31
- https://git.kernel.org/stable/c/39aaa337449e71a41d4813be0226a722827ba606
- https://git.kernel.org/stable/c/9f0e225635475b2285b966271d5e82cba74295b1
- https://git.kernel.org/stable/c/df82c7901513fd0fc738052a8e6a330d92cc8ec9
- https://git.kernel.org/stable/c/ec5430d090d0b6ace8fefa290fc37e88930017d2
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39870 or the next vulnerability affects your stack