What’s Vulnerable › Vulnerabilities
CVE-2025-39877: mm/damon/sysfs: fix use-after-free in state_show()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: mm/damon/sysfs: fix use-after-free in state_show() state_show() reads kdamond->damon_ctx without holding damon_sysfs_lock. This allows a use-after-free race: CPU 0 CPU 1 ----- ----- state_show() damon_sysfs_turn_damon_on() ctx = kdamond->damon_ctx; mutex_lock(&damon_sysfs_lock); damon_destroy_ctx(kdamond->damon_ctx); kdamond->damon_ctx = NULL; mutex_unlock(&damon_sysfs_lock); damon_is_running(ctx); /* ctx is freed */ mutex_lock(&ctx->kdamond_lock); /* UAF */ (The race can also occur with damon_sysfs_kdamonds_rm_dirs() and damon_sysfs_kdamond_release(), which free or replace the context under damon_sysfs_lock.) Fix by taking damon_sysfs_lock before dereferencing the context, mirroring the locking used in pid_show(). The bug has existed since state_show() first accessed kdamond->damon_ctx.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.18 before 6.1.153; from 6.2 before 6.6.107; from 6.7 before 6.12.48; from 6.13 before 6.16.8; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4, 6.17-rc5 — fixed in 6.1.153, 6.12.48, 6.16.8, 6.6.107
How to fix
Upgrade to a fixed version: Linux kernel 6.1.153, 6.12.48, 6.16.8, 6.6.107. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/26d29b2ac87a2989071755f9828ebf839b560d4c
- https://git.kernel.org/stable/c/3260a3f0828e06f5f13fac69fb1999a6d60d9cff
- https://git.kernel.org/stable/c/3858c44341ad49dc7544b19cc9f9ecffaa7cc50e
- https://git.kernel.org/stable/c/4e87f461d61959647464a94d11ae15c011be58ce
- https://git.kernel.org/stable/c/60d7a3d2b985a395318faa1d88da6915fad11c19
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39877 or the next vulnerability affects your stack