What’s Vulnerable › Vulnerabilities
CVE-2025-39880: libceph: fix invalid accesses to ceph_connection_v1_info
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-19
- Weakness: CWE-704
Description
In the Linux kernel, the following vulnerability has been resolved: libceph: fix invalid accesses to ceph_connection_v1_info There is a place where generic code in messenger.c is reading and another place where it is writing to con->v1 union member without checking that the union member is active (i.e. msgr1 is in use). On 64-bit systems, con->v1.auth_retry overlaps with con->v2.out_iter, so such a read is almost guaranteed to return a bogus value instead of 0 when msgr2 is in use. This ends up being fairly benign because the side effect is just the invalidation of the authorizer and successive fetching of new tickets. con->v1.connect_seq overlaps with con->v2.conn_bufs and the fact that it's being written to can cause more serious consequences, but luckily it's not something that happens often.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.11 before 5.15.194; from 5.16 before 6.1.153; from 6.2 before 6.6.107; from 6.7 before 6.12.48; from 6.13 before 6.16.8; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4, 6.17-rc5 — fixed in 5.15.194, 6.1.153, 6.12.48, 6.16.8, 6.6.107
How to fix
Upgrade to a fixed version: Linux kernel 5.15.194, 6.1.153, 6.12.48, 6.16.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/23538cfbeed87159a5ac6c61e7a6de3d8d4486a8
- https://git.kernel.org/stable/c/35dbbc3dbf8bccb2d77c68444f42c1e6d2d27983
- https://git.kernel.org/stable/c/591ea9c30737663a471b2bb07b27ddde86b020d5
- https://git.kernel.org/stable/c/6bd8b56899be0b514945f639a89ccafb8f8dfaef
- https://git.kernel.org/stable/c/cdbc9836c7afadad68f374791738f118263c5371
- https://git.kernel.org/stable/c/ea12ab684f8ae8a6da11a22c78d94a79e2163096
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39880 or the next vulnerability affects your stack