What’s Vulnerable › Vulnerabilities
CVE-2025-39888: fuse: Block access to folio overlimit
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-19
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: fuse: Block access to folio overlimit syz reported a slab-out-of-bounds Write in fuse_dev_do_write. When the number of bytes to be retrieved is truncated to the upper limit by fc->max_pages and there is an offset, the oob is triggered. Add a loop termination condition to prevent overruns.
Affected products
- Linux kernel: from 6.16 before 6.16.8; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4, 6.17-rc5 — fixed in 6.16.8
How to fix
Upgrade to a fixed version: Linux kernel 6.16.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/623719227b114d73a2cee45f1b343ced63ce09ec
- https://git.kernel.org/stable/c/9d81ba6d49a7457784f0b6a71046818b86ec7e44
Get alerted when CVE-2025-39888 or the next vulnerability affects your stack