What’s Vulnerable › Vulnerabilities
CVE-2025-39909: mm/damon/lru_sort: avoid divide-by-zero in damon_lru_sort_apply_parameters()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-19
- Weakness: CWE-369
Description
In the Linux kernel, the following vulnerability has been resolved: mm/damon/lru_sort: avoid divide-by-zero in damon_lru_sort_apply_parameters() Patch series "mm/damon: avoid divide-by-zero in DAMON module's parameters application". DAMON's RECLAIM and LRU_SORT modules perform no validation on user-configured parameters during application, which may lead to division-by-zero errors. Avoid the divide-by-zero by adding validation checks when DAMON modules attempt to apply the parameters. This patch (of 2): During the calculation of 'hot_thres' and 'cold_thres', either 'sample_interval' or 'aggr_interval' is used as the divisor, which may lead to division-by-zero errors. Fix it by directly returning -EINVAL when such a case occurs. Additionally, since 'aggr_interval' is already required to be set no smaller than 'sample_interval' in damon_set_attrs(), only the case where 'sample_interval' is zero needs to be checked.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 6.0 before 6.1.153; from 6.2 before 6.6.107; from 6.7 before 6.12.48; from 6.13 before 6.16.8; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4, 6.17-rc5 — fixed in 6.1.153, 6.12.48, 6.16.8, 6.6.107
How to fix
Upgrade to a fixed version: Linux kernel 6.1.153, 6.12.48, 6.16.8, 6.6.107. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/326a4b3750c71af3f3c52399ec4dbe33b6da4c26
- https://git.kernel.org/stable/c/711f19dfd783ffb37ca4324388b9c4cb87e71363
- https://git.kernel.org/stable/c/74e391f7da7d9d5235a3cca88ee9fc18f720c75b
- https://git.kernel.org/stable/c/7bb675c9f0257840d33e5d1337d7e3afdd74a6bf
- https://git.kernel.org/stable/c/af0ae62b935317bed1a1361c8c9579db9d300e70
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39909 or the next vulnerability affects your stack