What’s Vulnerable › Vulnerabilities
CVE-2025-39920: pcmcia: Add error handling for add_interval() in do_validate_mem()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-19
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: pcmcia: Add error handling for add_interval() in do_validate_mem() In the do_validate_mem(), the call to add_interval() does not handle errors. If kmalloc() fails in add_interval(), it could result in a null pointer being inserted into the linked list, leading to illegal memory access when sub_interval() is called next. This patch adds an error handling for the add_interval(). If add_interval() returns an error, the function will return early with the error code.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.34 before 5.4.299; from 5.5 before 5.10.243; from 5.11 before 5.15.192; from 5.16 before 6.1.151; from 6.2 before 6.6.105; from 6.7 before 6.12.46 — fixed in 5.10.243, 5.15.192, 5.4.299, 6.1.151, 6.12.46, 6.16.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.243, 5.15.192, 5.4.299, 6.1.151. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06b26e3099207c94b3d1be8565aedc6edc4f0a60
- https://git.kernel.org/stable/c/289b58f8ff3198d091074a751d6b8f6827726f3e
- https://git.kernel.org/stable/c/369bf6e241506583f4ee7593c53b92e5a9f271b4
- https://git.kernel.org/stable/c/4a81f78caa53e0633cf311ca1526377d9bff7479
- https://git.kernel.org/stable/c/5b60ed401b47897352c520bc724c85aa908dedcc
- https://git.kernel.org/stable/c/85be7ef8c8e792a414940a38d94565dd48d2f236
- https://git.kernel.org/stable/c/8699358b6ac99b8ccc97ed9e6e3669ef8958ef7b
- https://git.kernel.org/stable/c/ae184024ef31423e5beb44cf4f52999bbcf2fe5b
- https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39920 or the next vulnerability affects your stack