What’s Vulnerable › Vulnerabilities
CVE-2025-39923: dmaengine: qcom: bam_dma: Fix DT error handling for num-channels/ees
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: dmaengine: qcom: bam_dma: Fix DT error handling for num-channels/ees When we don't have a clock specified in the device tree, we have no way to ensure the BAM is on. This is often the case for remotely-controlled or remotely-powered BAM instances. In this case, we need to read num-channels from the DT to have all the necessary information to complete probing. However, at the moment invalid device trees without clock and without num-channels still continue probing, because the error handling is missing return statements. The driver will then later try to read the number of channels from the registers. This is unsafe, because it relies on boot firmware and lucky timing to succeed. Unfortunately, the lack of proper error handling here has been abused for several Qualcomm SoCs upstream, causing early boot crashes in several situations [1, 2]. Avoid these early crashes by erroring out when any of the required DT properties are missing. Note that this will break some of the existing DTs upstream (mainly BAM instances related to the crypto engine). However, clearly these DTs have never been tested properly, since the error in the kernel log was just ignored. It's safer to disable the crypto engine for these broken DTBs. [1]: https://lore.kernel.org/r/CY01EKQVWE36.B9X5TDXAREPF@fairphone.com/ [2]: https://lore.kernel.org/r/20230626145959.646747-1-krzysztof.kozlowski@linaro.org/
Affected products
- Debian Linux: 11.0
- Linux kernel: from 4.9.104 before 4.10; from 4.14.45 before 4.15; from 4.16.13 before 5.4.300; from 5.5 before 5.10.245; from 5.11 before 5.15.194; from 5.16 before 6.1.153 — fixed in 4.10, 4.15, 5.10.245, 5.15.194, 5.4.300, 6.1.153
How to fix
Upgrade to a fixed version: Linux kernel 4.10, 4.15, 5.10.245, 5.15.194. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ff9df758af7022d749718fb6b8385cc5693acf3
- https://git.kernel.org/stable/c/1d98ba204d8a6db0d986c7f1aefaa0dcd1c007a2
- https://git.kernel.org/stable/c/1fc14731f0be4885e60702b9596d14d9a79cf053
- https://git.kernel.org/stable/c/2e257a6125c63350f00dc42b9674f20fd3cf4a9f
- https://git.kernel.org/stable/c/5068b5254812433e841a40886e695633148d362d
- https://git.kernel.org/stable/c/555bd16351a35c79efb029a196975a5a27f7fbc4
- https://git.kernel.org/stable/c/6ac1599d0e78036d9d08efc2f58c2d91f0a3ee4c
- https://git.kernel.org/stable/c/ebf6c7c908e5999531c3517289598f187776124f
- https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html
Get alerted when CVE-2025-39923 or the next vulnerability affects your stack