What’s Vulnerable › Vulnerabilities
CVE-2025-39930: ASoC: simple-card-utils: Don't use __free(device_node) at graph_util_parse_dai()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-18 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: ASoC: simple-card-utils: Don't use __free(device_node) at graph_util_parse_dai() commit 419d1918105e ("ASoC: simple-card-utils: use __free(device_node) for device node") uses __free(device_node) for dlc->of_node, but we need to keep it while driver is in use. Don't use __free(device_node) in graph_util_parse_dai().
Affected products
- Linux kernel: from 6.14 before 6.14.2 — fixed in 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/146e25625378f7d4463acbd1ffbd975f3332a806
- https://git.kernel.org/stable/c/16a49e3fda339aa552cde7f2cdbb25b91426cb8a
- https://git.kernel.org/stable/c/232a32e8a7e9be8a2ee238df9b5304eed2f4e195
- https://git.kernel.org/stable/c/de74ec718e0788e1998eb7289ad07970e27cae27
Get alerted when CVE-2025-39930 or the next vulnerability affects your stack