What’s Vulnerable › Vulnerabilities
CVE-2025-39940: dm-stripe: fix a possible integer overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-10-21
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: dm-stripe: fix a possible integer overflow There's a possible integer overflow in stripe_io_hints if we have too large chunk size. Test if the overflow happened, and if it did, don't set limits->io_min and limits->io_opt;
Affected products
- Linux kernel: from 2.6.31.1 before 6.12.49; from 6.13 before 6.16.9; 2.6.31, 2.6.31-rc9, 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4 (+2) — fixed in 6.12.49, 6.16.9
How to fix
Upgrade to a fixed version: Linux kernel 6.12.49, 6.16.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1071d560afb4c245c2076494226df47db5a35708
- https://git.kernel.org/stable/c/891ab8c6954199e4f36029b49df86c8b1d6b0b2f
- https://git.kernel.org/stable/c/ee27658c239b27721397f3e4eb16370b5cce596e
- https://git.kernel.org/stable/c/f8f64254bca5ae58f3b679441962bda4c409f659
Get alerted when CVE-2025-39940 or the next vulnerability affects your stack