What’s Vulnerable › Vulnerabilities
CVE-2025-39942: ksmbd: smbdirect: verify remaining_data_length respects max_fragmented_recv_size
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: smbdirect: verify remaining_data_length respects max_fragmented_recv_size This is inspired by the check for data_offset + data_length.
Affected products
- Linux kernel: from 5.15.1 before 6.1.154; from 6.2 before 6.6.108; from 6.7 before 6.12.49; from 6.13 before 6.16.9; 5.15, 5.15-rc7, 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4 (+2) — fixed in 6.1.154, 6.12.49, 6.16.9, 6.6.108
How to fix
Upgrade to a fixed version: Linux kernel 6.1.154, 6.12.49, 6.16.9, 6.6.108. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/196a3a7676d726ee67621ea2bf3b7815ac2685b4
- https://git.kernel.org/stable/c/9644798294c7287e65a7b26e35aa6d2ce3345bcc
- https://git.kernel.org/stable/c/c64b915bb3d9339adcae5db4be2c35ffbef5e615
- https://git.kernel.org/stable/c/d3cb3f209d35c44b7ee74f77ed27ebb28995b9ce
- https://git.kernel.org/stable/c/e1868ba37fd27c6a68e31565402b154beaa65df0
Get alerted when CVE-2025-39942 or the next vulnerability affects your stack