What’s Vulnerable › Vulnerabilities
CVE-2025-39943: ksmbd: smbdirect: validate data_offset and data_length field of smb_direct_data_transfer
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-04 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: smbdirect: validate data_offset and data_length field of smb_direct_data_transfer If data_offset and data_length of smb_direct_data_transfer struct are invalid, out of bounds issue could happen. This patch validate data_offset and data_length field in recv_done.
Affected products
- Linux kernel: from 5.15.1 before 5.15.194; from 5.16 before 6.1.154; from 6.2 before 6.6.108; from 6.7 before 6.12.49; from 6.13 before 6.16.9; 5.15, 5.15-rc7, 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4 (+2) — fixed in 5.15.194, 6.1.154, 6.12.49, 6.16.9, 6.6.108
How to fix
Upgrade to a fixed version: Linux kernel 5.15.194, 6.1.154, 6.12.49, 6.16.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5282491fc49d5614ac6ddcd012e5743eecb6a67c
- https://git.kernel.org/stable/c/529b121b00a6ee3c88fb3c01b443b2b81f686d48
- https://git.kernel.org/stable/c/773fddf976d282ef059c36c575ddb81567acd6bc
- https://git.kernel.org/stable/c/8be498fcbd5b07272f560b45981d4b9e5a2ad885
- https://git.kernel.org/stable/c/bdaab5c6538e250a9654127e688ecbbeb6f771d5
- https://git.kernel.org/stable/c/eb0378dde086363046ed3d7db7f126fc3f76fd70
Get alerted when CVE-2025-39943 or the next vulnerability affects your stack