What’s Vulnerable › Vulnerabilities
CVE-2025-39960: gpiolib: acpi: initialize acpi_gpio_info struct
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-09 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: gpiolib: acpi: initialize acpi_gpio_info struct Since commit 7c010d463372 ("gpiolib: acpi: Make sure we fill struct acpi_gpio_info"), uninitialized acpi_gpio_info struct are passed to __acpi_find_gpio() and later in the call stack info->quirks is used in acpi_populate_gpio_lookup. This breaks the i2c_hid_cpi driver: [ 58.122916] i2c_hid_acpi i2c-UNIW0001:00: HID over i2c has not been provided an Int IRQ [ 58.123097] i2c_hid_acpi i2c-UNIW0001:00: probe with driver i2c_hid_acpi failed with error -22 Fix this by initializing the acpi_gpio_info pass to __acpi_find_gpio()
Affected products
- Linux kernel: from 6.16 before 6.16.9; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4, 6.17-rc5, 6.17-rc6 — fixed in 6.16.9
How to fix
Upgrade to a fixed version: Linux kernel 6.16.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/19c839a98c731169f06d32e7c9e00c78a0086ebe
- https://git.kernel.org/stable/c/27d94a2a52cbb54927c0140bd5b978c56e9a283a
Get alerted when CVE-2025-39960 or the next vulnerability affects your stack