What’s Vulnerable › Vulnerabilities
CVE-2025-39964: Linux Kernel Race Condition Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-18
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-13 · updated 2026-10-19
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: af_alg - Disallow concurrent writes in af_alg_sendmsg Issuing two writes to the same af_alg socket is bogus as the data will be interleaved in an unpredictable fashion. Furthermore, concurrent writes may create inconsistencies in the internal socket state. Disallow this by adding a new ctx->write field that indiciates exclusive ownership for writing.
Affected products
- Linux kernel: from 2.6.38 before 5.10.245; from 5.11 before 5.15.194; from 5.16 before 6.1.154; from 6.2 before 6.6.108; from 6.7 before 6.12.49; from 6.13 before 6.16.9 — fixed in 5.10.245, 5.15.194, 6.1.154, 6.12.49, 6.16.9, 6.6.108
- Siemens Simatic S7-1500 Cpu 1518-4 Pn/Dp Mfp Firmware: from 3.1.6
- Siemens Simatic S7-1500 Cpu 1518F-4 Pn/Dp Mfp Firmware: from 3.1.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.245, 5.15.194, 6.1.154, 6.12.49. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f28c4adbc4a97437874c9b669fd7958a8c6d6ce
- https://git.kernel.org/stable/c/1b34cbbf4f011a121ef7b2d7d6e6920a036d5285
- https://git.kernel.org/stable/c/1f323a48e9b5ebfe6dc7d130fdf5c3c0e92a07c8
- https://git.kernel.org/stable/c/45bcf60fe49b37daab1acee57b27211ad1574042
- https://git.kernel.org/stable/c/7c4491b5644e3a3708f3dbd7591be0a570135b84
- https://git.kernel.org/stable/c/9aee87da5572b3a14075f501752e209801160d3d
- https://git.kernel.org/stable/c/e4c1ec11132ec466f7362a95f36a506ce4dc08c9
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-39964
Get alerted when CVE-2025-39964 or the next vulnerability affects your stack