What’s Vulnerable › Vulnerabilities
CVE-2025-39965: xfrm: xfrm_alloc_spi shouldn't use 0 as SPI
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-13 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: xfrm: xfrm_alloc_spi shouldn't use 0 as SPI x->id.spi == 0 means "no SPI assigned", but since commit 94f39804d891 ("xfrm: Duplicate SPI Handling"), we now create states and add them to the byspi list with this value. __xfrm_state_delete doesn't remove those states from the byspi list, since they shouldn't be there, and this shows up as a UAF the next time we go through the byspi list.
Affected products
- Linux kernel: from 6.6.103 before 6.6.109; from 6.12.43 before 6.12.50; from 6.15.11 before 6.16; from 6.16.2 before 6.16.10; 6.17-rc1, 6.17-rc2, 6.17-rc3, 6.17-rc4, 6.17-rc5, 6.17-rc6 (+1) — fixed in 6.6.109, 6.12.50, 6.16, 6.16.10
- Linux: from 6.1.191 before 6.2; from 6.15.11 before 6.16 — fixed in 6.2, 6.16
How to fix
Upgrade to a fixed version: Linux kernel 6.6.109, 6.12.50, 6.16, 6.16.10; Linux 6.2, 6.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0baf92d0b1590b903c1f4ead75e61715e50e8146
- https://git.kernel.org/stable/c/9fcedabaae0096f712bbb4ccca6a8538af1cd1c8
- https://git.kernel.org/stable/c/a78e55776522373c446f18d5002a8de4b09e6bf7
- https://git.kernel.org/stable/c/cd8ae32e4e4652db55bce6b9c79267d8946765a9
Get alerted when CVE-2025-39965 or the next vulnerability affects your stack