What’s Vulnerable › Vulnerabilities
CVE-2025-39975: smb: client: fix wrong index reference in smb2_compound_op()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-15 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: smb: client: fix wrong index reference in smb2_compound_op() In smb2_compound_op(), the loop that processes each command's response uses wrong indices when accessing response bufferes. This incorrect indexing leads to improper handling of command results. Also, if incorrectly computed index is greather than or equal to MAX_COMPOUND, it can cause out-of-bounds accesses.
Affected products
- Linux kernel: from 6.6.75 before 6.6.109; from 6.12.12 before 6.12.50; from 6.13.1 before 6.14; 6.14 — fixed in 6.12.50, 6.14, 6.17, 6.6.109
How to fix
Upgrade to a fixed version: Linux kernel 6.12.50, 6.14, 6.17, 6.6.109. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/093615fc76063ea08d454ba86677ce64c736e806
- https://git.kernel.org/stable/c/ba7bcfd52c66dd1c2dfa5142aca7e4a70b62dfa5
- https://git.kernel.org/stable/c/bfb1e2aad1fecef8320fd71332acde0d53a8d699
- https://git.kernel.org/stable/c/fbe2dc6a9c7318f7263f5e4d50f6272b931c5756
Get alerted when CVE-2025-39975 or the next vulnerability affects your stack