What’s Vulnerable › Vulnerabilities
CVE-2025-4008: Smartbedded Meteobridge Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-10-02
- EPSS: 93.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-21 · updated 2026-06-17
- Weakness: CWE-77
Description
The Meteobridge web interface let meteobridge administrator manage their weather station data collection and administer their meteobridge system through a web application written in CGI shell scripts and C. This web interface exposes an endpoint that is vulnerable to command injection. Remote unauthenticated attackers can gain arbitrary command execution with elevated privileges ( root ) on affected devices.
Affected products
- Smartbedded Meteobridge Firmware: before 6.2 — fixed in 6.2
- Smartbedded Meteobridge Vm: before 6.2 — fixed in 6.2
How to fix
Upgrade to a fixed version: Smartbedded Meteobridge Firmware 6.2; Smartbedded Meteobridge Vm 6.2. Check the vendor advisory for mitigations.
References
- https://forum.meteohub.de/viewtopic.php?t=18687
- https://www.onekey.com/resource/security-advisory-remote-command-execution-on-smartbedded-meteobridge-cve-2025-4008
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-4008
Get alerted when CVE-2025-4008 or the next vulnerability affects your stack