What’s Vulnerable › Vulnerabilities
CVE-2025-4010: Arbitrary Command Injection in Netcom NTC-6200 & NWL-222
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-02 · updated 2026-06-17
- Weakness: CWE-77
Description
The Netcom NTC 6200 and NWL 222 series expose a web interface to be configured and set up by operators. Multiple endpoints of the web interface are vulnerable to arbitrary command injection and use insecure hardcoded passwords. Remote authenticated attackers can gain arbitrary code execution with elevated privileges.
Affected products
- Netcomm NTC 6200: 0
- Netcomm NWL-222: before 2.1.21.1 — fixed in 2.1.21.1
How to fix
Upgrade to a fixed version: Netcomm NWL-222 2.1.21.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4010 or the next vulnerability affects your stack