What’s Vulnerable › Vulnerabilities
CVE-2025-40300: x86/vmscape: Add conditional IBPB mitigation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-11 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: x86/vmscape: Add conditional IBPB mitigation VMSCAPE is a vulnerability that exploits insufficient branch predictor isolation between a guest and a userspace hypervisor (like QEMU). Existing mitigations already protect kernel/KVM from a malicious guest. Userspace can additionally be protected by flushing the branch predictors after a VMexit. Since it is the userspace that consumes the poisoned branch predictors, conditionally issue an IBPB after a VMexit and before returning to userspace. Workloads that frequently switch between hypervisor and userspace will incur the most overhead from the new IBPB. This new IBPB is not integrated with the existing IBPB sites. For instance, a task can use the existing speculation control prctl() to get an IBPB at context switch time. With this implementation, the IBPB is doubled up: one at context switch and another before running userspace. The intent is to integrate and optimize these cases post-embargo. [ dhansen: elaborate on suboptimal IBPB solution ]
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.16.57 before 3.17; from 4.4.168 before 4.5; from 4.16 before 5.10.244; from 5.11 before 5.15.193; from 5.16 before 6.1.152; from 6.2 before 6.6.106 — fixed in 3.17, 4.5, 5.10.244, 5.15.193, 6.1.152, 6.12.47
How to fix
Upgrade to a fixed version: Linux kernel 3.17, 4.5, 5.10.244, 5.15.193. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/15006289e5c38b2a830e1fba221977a27598176c
- https://git.kernel.org/stable/c/2f4f2f8f860cb4c3336a7435ebe8dcfded0c9c6e
- https://git.kernel.org/stable/c/2f8f173413f1cbf52660d04df92d0069c4306d25
- https://git.kernel.org/stable/c/34e5667041050711a947e260fc9ebebe08bddee5
- https://git.kernel.org/stable/c/459274c77b37ac63b78c928b4b4e748d1f9d05c8
- https://git.kernel.org/stable/c/510603f504796c3535f67f55fb0b124a303b44c8
- https://git.kernel.org/stable/c/893387c18612bb452336a5881da0d015a7e8f4a2
- https://git.kernel.org/stable/c/9c23a90648e831d611152ac08dbcd1283d405e7f
- https://git.kernel.org/stable/c/ac60717f9a8d21c58617d0b34274babf24135835
- https://git.kernel.org/stable/c/c08192b5d6730a914dee6175bc71092ee6a65f14
- https://git.kernel.org/stable/c/d5490dfa35427a2967e00a4c7a1b95fdbc8ede34
- https://git.kernel.org/stable/c/d7ddc93392e4a7ffcccc86edf6ef3e64c778db52
Get alerted when CVE-2025-40300 or the next vulnerability affects your stack