What’s Vulnerable › Vulnerabilities
CVE-2025-40539: SolarWinds Serv-U Type Confusion Remote Code Execution Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-704
Description
A type confusion vulnerability exists in Serv-U which when exploited, gives a malicious actor the ability to execute arbitrary native code as privileged account. This issue requires administrative privileges to abuse. On Windows deployments, the risk is scored as a medium because services frequently run under less-privileged service accounts by default.
Affected products
- SolarWinds Serv-U: before 15.5.4 — fixed in 15.5.4
How to fix
Upgrade to a fixed version: SolarWinds Serv-U 15.5.4. Check the vendor advisory for mitigations.
References
- https://documentation.solarwinds.com/en/success_center/servu/content/release_notes/servu_15-5-4_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2025-40539
Get alerted when CVE-2025-40539 or the next vulnerability affects your stack