What’s Vulnerable › Vulnerabilities
CVE-2025-40547: SolarWinds Serv-U Logic Abuse - Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-18 · updated 2026-10-18
- Weakness: CWE-116
Description
A logic error vulnerability exists in Serv-U which when abused could give a malicious actor with access to admin privileges the ability to execute code. This issue requires administrative privileges to abuse. On Windows deployments, the risk is scored as a medium because services frequently run under less-privileged service accounts by default.
Affected products
- SolarWinds Serv-U: before 15.5.3 — fixed in 15.5.3
How to fix
Upgrade to a fixed version: SolarWinds Serv-U 15.5.3. Check the vendor advisory for mitigations.
References
- https://documentation.solarwinds.com/en/success_center/servu/content/release_notes/servu_15-5-3_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/CVE-2025-40547
Get alerted when CVE-2025-40547 or the next vulnerability affects your stack