What’s Vulnerable › Vulnerabilities
CVE-2025-40758
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-347
Description
A vulnerability has been identified in Mendix SAML (Mendix 10.12 compatible) (All versions < V4.0.3), Mendix SAML (Mendix 10.21 compatible) (All versions < V4.1.2), Mendix SAML (Mendix 9.24 compatible) (All versions < V3.6.21). Affected versions of the module insufficiently enforce signature validation and binding checks. This could allow unauthenticated remote attackers to hijack an account in specific SSO configurations.
Affected products
- Siemens Mendix SAML (Mendix 10.12 compatible): before V4.0.3 — fixed in V4.0.3
- Siemens Mendix SAML (Mendix 10.21 compatible): before V4.1.2 — fixed in V4.1.2
- Siemens Mendix SAML (Mendix 9.24 compatible): before V3.6.21 — fixed in V3.6.21
How to fix
Upgrade to a fixed version: Siemens Mendix SAML (Mendix 10.12 compatible) V4.0.3; Siemens Mendix SAML (Mendix 10.21 compatible) V4.1.2; Siemens Mendix SAML (Mendix 9.24 compatible) V3.6.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-40758 or the next vulnerability affects your stack