What’s Vulnerable › Vulnerabilities
CVE-2025-40763
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-427
Description
A vulnerability has been identified in Altair Grid Engine (All versions < V2026.0.0). Affected products do not properly validate environment variables when loading shared libraries, allowing path hijacking through malicious library substitution. This could allow a local attacker to execute arbitrary code with superuser privileges by manipulating the environment variable and placing a malicious library in the controlled path.
Affected products
- Siemens Altair Grid Engine: before V2026.0.0 — fixed in V2026.0.0
How to fix
Upgrade to a fixed version: Siemens Altair Grid Engine V2026.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-40763 or the next vulnerability affects your stack