What’s Vulnerable › Vulnerabilities
CVE-2025-40834
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-17 · updated 2026-10-23
- Weakness: CWE-79
Description
A vulnerability has been identified in Mendix RichText (All versions >= V4.0.0 < V4.6.1). Affected widget does not properly neutralize the input. This could allow an attacker to execute cross-site scripting attacks.
Affected products
- Siemens Mendix RichText: from V4.0.0 before V4.6.1 — fixed in V4.6.1
How to fix
Upgrade to a fixed version: Siemens Mendix RichText V4.6.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-40834 or the next vulnerability affects your stack