What’s Vulnerable › Vulnerabilities
CVE-2025-40843: Buffer overflow in CodeChecker log command
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-28 · updated 2026-10-08
- Weakness: CWE-121
Description
CodeChecker is an analyzer tooling, defect database and viewer extension for the Clang Static Analyzer and Clang Tidy. CodeChecker versions up to 6.26.1 contain a buffer overflow vulnerability in the internal ldlogger library, which is executed by the CodeChecker log command. This issue affects CodeChecker: through 6.26.1.
Affected products
- Ericsson CodeChecker: before 6.26.2 — fixed in 6.26.2
How to fix
Upgrade to a fixed version: Ericsson CodeChecker 6.26.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-40843 or the next vulnerability affects your stack